New agents created gives null pointer exception

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

New agents created gives null pointer exception

priyapal
I installed a 2 new  agent , on the same hot
When i try to deploy , one agent is deployed fine but another agent gives me the following error , though there is nothing different from agents set up other than their location and names

I get a Null Pointer exception showing the following in the agent log

Have anyone come across this error before??


2011-03-07 15:31:40,407 - An error occurred accessing the Codestation Repository at http://xxx:18080/. It is defined in the System - Server Settings page as the External URL value. If this URL is incorrect, please change it. Detailed error message: com.urbancode.codestation2.client.exception.InvalidCredentialsException: Unauthorized
2011-03-07 15:31:40,472 - Transfer of logs was not successful. Server returned status '401'.
2011-03-07 15:32:34,223 - Transfer of logs was not successful. Server returned status '401'.
2011-03-07 15:32:34,224 - Error recovering CommandInfo from file /opt/apache/agents/xxxx/var/jobs/1299511954129/result.ser for handle:
com.urbancode.devilfish.common.Handle {
  handle:      1299511954129
  serviceName: Command
  machineName: null
}
java.io.FileNotFoundException: /opt/xxxe/agents/xxxx/var/jobs/1299511954129/result.ser (No such file or directory)
        at java.io.FileInputStream.open(Native Method)
        at java.io.FileInputStream.<init>(FileInputStream.java:106)
        at com.urbancode.devilfish.services.command.CommandService.getSerializedCommandInfoForHandle(CommandService.java:448)
        at com.urbancode.devilfish.services.command.jms.GetResultRequest.execute(GetResultRequest.java:72)
        at com.urbancode.devilfish.services.command.jms.GetResultRequest.execute(GetResultRequest.java:8)
        at com.urbancode.devilfish.services.command.jms.CommandServiceRequest.execute(CommandServiceRequest.java:51)
        at com.urbancode.devilfish.server.jms.DevilfishTask.call(DevilfishTask.java:67)
        at com.urbancode.devilfish.server.jms.DevilfishTask.call(DevilfishTask.java:12)
        at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
        at java.util.concurrent.FutureTask.run(FutureTask.java:138)
        at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
        at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
        at java.util.concurrent.FutureTask.run(FutureTask.java:138)
        at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
        at java.lang.Thread.run(Thread.java:619)
Reply | Threaded
Open this post in threaded view
|

Re: New agents created gives null pointer exception

AnthillizerDotCom
Seems like a permissions issue...

/opt/xxxe/agents/xxxx

Can you confirm if the user (the user that the Anthill agent is running as) has write access?


Eric Starr

On Mar 7, 2011, at 10:52 AM, priyapal <[hidden email]> wrote:

> java.io.FileNotFoundException:
> /opt/xxxe/agents/xxxx/var/jobs/1299511954129
_______________________________________________
Anthill-pro mailing list
[hidden email]
http://lists.urbancode.com/mailman/listinfo/anthill-pro
Eric Starr Anthillizer.com
Reply | Threaded
Open this post in threaded view
|

Re: New agents created gives null pointer exception

priyapal
Hi eric

The user in the agent does have the write permission .

If the remove the agent completely and reinstall it again it , it works fine with the same credentials which had before .

but i see this issue often if i create 2 agents on the same host , where one agent runs fine and get deployed but the other agent shows deployment error as mentioned above
Reply | Threaded
Open this post in threaded view
|

Re: New agents created gives null pointer exception

Brian Kelly
What requires you two run two agents on one machine in the first place?

-brian

On 3/7/11 1:01 PM, "priyapal" <[hidden email]> wrote:

> Hi eric
>
> The user in the agent does have the write permission .
>
> If the remove the agent completely and reinstall it again it , it works fine
> with the same credentials which had before .
>
> but i see this issue often if i create 2 agents on the same host , where one
> agent runs fine and get deployed but the other agent shows deployment error
> as mentioned above
>
> --
> View this message in context:
> http://anthill-pro.1594311.n2.nabble.com/New-agents-created-gives-null-pointer
> -exception-tp6097771p6098280.html
> Sent from the Anthill-Pro mailing list archive at Nabble.com.
> _______________________________________________
> Anthill-pro mailing list
> [hidden email]
> http://lists.urbancode.com/mailman/listinfo/anthill-pro

Brian Kelly
Build & Deploy Architect
Time Inc. Information Technology
Email: [hidden email]
Phone: (212) 522-2464
IM: TimeIncBri

_______________________________________________
Anthill-pro mailing list
[hidden email]
http://lists.urbancode.com/mailman/listinfo/anthill-pro
Reply | Threaded
Open this post in threaded view
|

Re: New agents created gives null pointer exception

priyapal
Hi Brian

We run 2 agent to have tomcat and apache deployed to the host , this have worked in the past ...but sometimes i see this error , which iam not able to figure out the reason

Thanks
Priya
Reply | Threaded
Open this post in threaded view
|

Re: New agents created gives null pointer exception

Brian Kelly
Why can't you deploy Tomcat and Apache using one Agent?

Is it because you have one Agent running as the Tomcat user and one Agent
running as the Apache user for security reasons?

-brian

On 3/7/11 2:15 PM, "priyapal" <[hidden email]> wrote:

> tomcat and apache deployed to the host

Brian Kelly
Build & Deploy Architect
Time Inc. Information Technology
Email: [hidden email]
Phone: (212) 522-2464
IM: TimeIncBri

_______________________________________________
Anthill-pro mailing list
[hidden email]
http://lists.urbancode.com/mailman/listinfo/anthill-pro
Reply | Threaded
Open this post in threaded view
|

Re: New agents created gives null pointer exception

priyapal
We have 2 agents and 2 different users ,
i am just wondering why am i getting this error sometimes , but when i remove and reinstall the agent again it works perfectly well.