Help needed with JDK setup

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Help needed with JDK setup

adela.bugariu

Hello,

We are having problems with setting up the JDK version (1.5) for a new project.
The rest of our projects are still using JDK 1.4 so I hardcoded the JAVA_HOME path at project level for the new project.
But the build failed with the following error:
  [jrc] bad class file: C:\Program Files\Java\jdk1.5.0_14\jre\lib\rt.jar(java/lang/Object.class)
  [jrc] class file has wrong version 49.0, should be 48.0
  [jrc] Please remove or make sure it appears in the correct subdirectory of the classpath.
  [jrc] public class LetterGenerator extends JREvaluator  

If I run the build.xml file manually it's working.  It's not working if I build the project from AntHill.

Is it possible that starting with Anthill using JDK 1.4, now when changing to 1.5 there might be library compatibility issues between 1.5 and 1.4?

Thank you!
Adela Bugariu
ACI Worldwide Eastern Europe Development
Str. Pestalozzi nr. 22
Timisoara 300115, ROMANIA
Tel: +40 356 434 920
Fax: +40 256 200223

Email: [hidden email]
__________________________________________
This email message and any attachments may contain confidential, proprietary or non-public information.  The information is intended solely for the designated recipient(s).  If an addressing or transmission error has misdirected this email, please notify the sender immediately and destroy this email.  Any review, dissemination, use or reliance upon this information by unintended recipients is prohibited.  Any opinions expressed in this email are those of the author personally.

_______________________________________________
Anthill-pro mailing list
[hidden email]
http://lists.urbancode.com/mailman/listinfo/anthill-pro
Reply | Threaded
Open this post in threaded view
|

Re: Help needed with JDK setup

emerson cargnin
How did you hardcoded it?
Maybe you are trying to run the jrc with 1.4 but pointing the
JAVA_HOME to 1.5. Hard to tell without knowing how you are doing it...

2009/1/12  <[hidden email]>:

>
> Hello,
>
> We are having problems with setting up the JDK version (1.5) for a new
> project.
> The rest of our projects are still using JDK 1.4 so I hardcoded the
> JAVA_HOME path at project level for the new project.
> But the build failed with the following error:
>   [jrc] bad class file: C:\Program
> Files\Java\jdk1.5.0_14\jre\lib\rt.jar(java/lang/Object.class)
>   [jrc] class file has wrong version 49.0, should be 48.0
>   [jrc] Please remove or make sure it appears in the correct subdirectory of
> the classpath.
>   [jrc] public class LetterGenerator extends JREvaluator
>
> If I run the build.xml file manually it's working.  It's not working if I
> build the project from AntHill.
>
> Is it possible that starting with Anthill using JDK 1.4, now when changing
> to 1.5 there might be library compatibility issues between 1.5 and 1.4?
>
> Thank you!
> Adela Bugariu
> ACI Worldwide Eastern Europe Development
> Str. Pestalozzi nr. 22
> Timisoara 300115, ROMANIA
> Tel: +40 356 434 920
> Fax: +40 256 200223
>
> Email: [hidden email]
> __________________________________________
> This email message and any attachments may contain confidential, proprietary
> or non-public information.  The information is intended solely for the
> designated recipient(s).  If an addressing or transmission error has
> misdirected this email, please notify the sender immediately and destroy
> this email.  Any review, dissemination, use or reliance upon this
> information by unintended recipients is prohibited.  Any opinions expressed
> in this email are those of the author personally.
> _______________________________________________
> Anthill-pro mailing list
> [hidden email]
> http://lists.urbancode.com/mailman/listinfo/anthill-pro
>
>
_______________________________________________
Anthill-pro mailing list
[hidden email]
http://lists.urbancode.com/mailman/listinfo/anthill-pro
Reply | Threaded
Open this post in threaded view
|

Re: Help needed with JDK setup

adela.bugariu

I solved the problem :)
I changed the JAVA_HOME to 1.5  for that  project  (from Administration -> Build job for-> edit the Ant Builder and there I harcoded the Java Home Var)
But there (at Environment Vars tab) must be setup also the 1.5 CLASSPATH and PATH:
   PATH=C:\Program Files\Java\jdk1.5.0_14\bin;C:\Program Files\Java\jdk1.5.0_14\jre\bin;
  CLASSPATH=C:\Program Files\Java\jdk1.5.0_14\jre\lib\rt.jar

Have a nice day!
Adela Bugariu
ACI Worldwide Eastern Europe Development
Str. Pestalozzi nr. 22
Timisoara 300115, ROMANIA
Tel: +40 356 434 920
Fax: +40 256 200223

Email: [hidden email]
__________________________________________
This email message and any attachments may contain confidential, proprietary or non-public information.  The information is intended solely for the designated recipient(s).  If an addressing or transmission error has misdirected this email, please notify the sender immediately and destroy this email.  Any review, dissemination, use or reliance upon this information by unintended recipients is prohibited.  Any opinions expressed in this email are those of the author personally.



"emerson cargnin" <[hidden email]>
Sent by: [hidden email]

14-Jan-2009 02:20 PM

Please respond to
"AnthillPro user and support list." <[hidden email]>

To
"AnthillPro user and support list." <[hidden email]>
cc
Subject
Re: [Anthill-pro] Help needed with JDK setup





How did you hardcoded it?
Maybe you are trying to run the jrc with 1.4 but pointing the
JAVA_HOME to 1.5. Hard to tell without knowing how you are doing it...

2009/1/12  <[hidden email]>:
>
> Hello,
>
> We are having problems with setting up the JDK version (1.5) for a new
> project.
> The rest of our projects are still using JDK 1.4 so I hardcoded the
> JAVA_HOME path at project level for the new project.
> But the build failed with the following error:
>   [jrc] bad class file: C:\Program
> Files\Java\jdk1.5.0_14\jre\lib\rt.jar(java/lang/Object.class)
>   [jrc] class file has wrong version 49.0, should be 48.0
>   [jrc] Please remove or make sure it appears in the correct subdirectory of
> the classpath.
>   [jrc] public class LetterGenerator extends JREvaluator
>
> If I run the build.xml file manually it's working.  It's not working if I
> build the project from AntHill.
>
> Is it possible that starting with Anthill using JDK 1.4, now when changing
> to 1.5 there might be library compatibility issues between 1.5 and 1.4?
>
> Thank you!
> Adela Bugariu
> ACI Worldwide Eastern Europe Development
> Str. Pestalozzi nr. 22
> Timisoara 300115, ROMANIA
> Tel: +40 356 434 920
> Fax: +40 256 200223
>
> Email: [hidden email]
> __________________________________________
> This email message and any attachments may contain confidential, proprietary
> or non-public information.  The information is intended solely for the
> designated recipient(s).  If an addressing or transmission error has
> misdirected this email, please notify the sender immediately and destroy
> this email.  Any review, dissemination, use or reliance upon this
> information by unintended recipients is prohibited.  Any opinions expressed
> in this email are those of the author personally.
> _______________________________________________
> Anthill-pro mailing list
> [hidden email]
>
http://lists.urbancode.com/mailman/listinfo/anthill-pro
>
>
_______________________________________________
Anthill-pro mailing list
Anthill-pro@...
http://lists.urbancode.com/mailman/listinfo/anthill-pro


_______________________________________________
Anthill-pro mailing list
[hidden email]
http://lists.urbancode.com/mailman/listinfo/anthill-pro