Codestation cache directory lock

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Codestation cache directory lock

Gurinder.Randhawa

We are having a problem with "resolve artifact step" , we are unable to retrieve published EAR artifact. We are noticing a local and remote agent both showing the following in codestation cache directory.
All dependent project artifacts get retrieved ok and don't have directory locks.

Any idea what causes this, the same artifact set is used for project and its dependencies?

=========================================================================
[anthill@build 1050]$ ls -la
total 2
drwxrwxr-x 2 anthill anthill 1024 Dec 23 17:11 .
drwxrwxr-x 3 anthill anthill 1024 Dec 23 16:59 ..
-rw-rw-r-- 1 anthill anthill    0 Dec 23 17:03 .dir.accessed
-rw-rw-r-- 1 anthill anthill    0 Dec 23 16:59 .dir.lock


DIRECTORY PATH:
"~.codestation/cache/Venture-EAR_-_Full_Build/1050/Venture Deployables"
=========================================================================

--Gurinder
_______________________________________________
Anthill-pro mailing list
[hidden email]
http://lists.urbancode.com/mailman/listinfo/anthill-pro
Reply | Threaded
Open this post in threaded view
|

Re: Codestation cache directory lock

Gurinder.Randhawa

Anyone from UrbanCode able to help us resolve this issue?

--Gurinder



From: [hidden email]
To: [hidden email]
Date: 05/01/2009 02:53 PM
Subject: [Anthill-pro] Codestation cache directory lock






We are having a problem with "resolve artifact step" , we are unable to retrieve published EAR artifact. We are noticing a local and remote agent both showing the following in codestation cache directory.
All dependent project artifacts get retrieved ok and don't have directory locks.


Any idea what causes this, the same artifact set is used for project and its dependencies?


=========================================================================

[anthill@build 1050]$ ls -la

total 2

drwxrwxr-x 2 anthill anthill 1024 Dec 23 17:11 .

drwxrwxr-x 3 anthill anthill 1024 Dec 23 16:59 ..

-rw-rw-r-- 1 anthill anthill    0 Dec 23 17:03 .dir.accessed

-rw-rw-r-- 1 anthill anthill    0 Dec 23 16:59 .dir.lock



DIRECTORY PATH:

"~.codestation/cache/Venture-EAR_-_Full_Build/1050/Venture Deployables"

=========================================================================


--Gurinder
_______________________________________________
Anthill-pro mailing list
[hidden email]
http://lists.urbancode.com/mailman/listinfo/anthill-pro



_______________________________________________
Anthill-pro mailing list
[hidden email]
http://lists.urbancode.com/mailman/listinfo/anthill-pro
Reply | Threaded
Open this post in threaded view
|

Re: Codestation cache directory lock

Eric Minick
I'm frankly not too sure what's going on here. You might try disabling
caching temporarily to see if the cache behavior is the problem or not.
To do that, add an agent variable named "codestation.noCache" and set
the value to "true" and retry that deployment.

I'm curious to if this is a caching issue or something wrong with this
builds' artifact set on the central server.

-- Eric

[hidden email] wrote:

>
> Anyone from UrbanCode able to help us resolve this issue?
>
> --Gurinder
>
>
> From: [hidden email]
> To: [hidden email]
> Date: 05/01/2009 02:53 PM
> Subject: [Anthill-pro] Codestation cache directory lock
>
>
> ------------------------------------------------------------------------
>
>
>
>
> We are having a problem with "resolve artifact step" , we are unable
> to retrieve published EAR artifact. We are noticing a local and remote
> agent both showing the following in codestation cache directory.
> All dependent project artifacts get retrieved ok and don't have
> directory locks.
>
> Any idea what causes this, the same artifact set is used for project
> and its dependencies?
>
> =========================================================================
> [anthill@build 1050]$ ls -la
> total 2
> drwxrwxr-x 2 anthill anthill 1024 Dec 23 17:11 .
> drwxrwxr-x 3 anthill anthill 1024 Dec 23 16:59 ..
> -rw-rw-r-- 1 anthill anthill    0 Dec 23 17:03 .dir.accessed
> -rw-rw-r-- 1 anthill anthill    0 Dec 23 16:59 .dir.lock
>
>
> DIRECTORY PATH:
> "~.codestation/cache/Venture-EAR_-_Full_Build/1050/Venture Deployables"
> =========================================================================
>
> --Gurinder_______________________________________________
> Anthill-pro mailing list
> [hidden email]
> http://lists.urbancode.com/mailman/listinfo/anthill-pro
>
>
> ------------------------------------------------------------------------
>
> _______________________________________________
> Anthill-pro mailing list
> [hidden email]
> http://lists.urbancode.com/mailman/listinfo/anthill-pro
>  
_______________________________________________
Anthill-pro mailing list
[hidden email]
http://lists.urbancode.com/mailman/listinfo/anthill-pro
Reply | Threaded
Open this post in threaded view
|

Re: Codestation cache directory lock

Gurinder.Randhawa

Eric

This works fine, so this seems like a problem with caching? Strange why i don't have problem with other projects, it would be nice to keep
caching turned on for performance reasons.

Also the artifact set is the same across all projects.

--Gurinder


From: Eric Minick <[hidden email]>
To: "AnthillPro user and support list." <[hidden email]>
Date: 07/01/2009 01:52 PM
Subject: Re: [Anthill-pro] Codestation cache directory lock





I'm frankly not too sure what's going on here. You might try disabling
caching temporarily to see if the cache behavior is the problem or not.
To do that, add an agent variable named "codestation.noCache" and set
the value to "true" and retry that deployment.

I'm curious to if this is a caching issue or something wrong with this
builds' artifact set on the central server.

-- Eric

[hidden email] wrote:
>
> Anyone from UrbanCode able to help us resolve this issue?
>
> --Gurinder
>
>
> From:                  [hidden email]
> To:                  [hidden email]
> Date:                  05/01/2009 02:53 PM
> Subject:                  [Anthill-pro] Codestation cache directory lock
>
>
> ------------------------------------------------------------------------
>
>
>
>
> We are having a problem with "resolve artifact step" , we are unable
> to retrieve published EAR artifact. We are noticing a local and remote
> agent both showing the following in codestation cache directory.
> All dependent project artifacts get retrieved ok and don't have
> directory locks.
>
> Any idea what causes this, the same artifact set is used for project
> and its dependencies?
>
> =========================================================================
> [anthill@build 1050]$ ls -la
> total 2
> drwxrwxr-x 2 anthill anthill 1024 Dec 23 17:11 .
> drwxrwxr-x 3 anthill anthill 1024 Dec 23 16:59 ..
> -rw-rw-r-- 1 anthill anthill    0 Dec 23 17:03 .dir.accessed
> -rw-rw-r-- 1 anthill anthill    0 Dec 23 16:59 .dir.lock
>
>
> DIRECTORY PATH:
> "~.codestation/cache/Venture-EAR_-_Full_Build/1050/Venture Deployables"
> =========================================================================
>
> --Gurinder_______________________________________________
> Anthill-pro mailing list
> [hidden email]
>
http://lists.urbancode.com/mailman/listinfo/anthill-pro
>
>
> ------------------------------------------------------------------------
>
> _______________________________________________
> Anthill-pro mailing list
> [hidden email]
>
http://lists.urbancode.com/mailman/listinfo/anthill-pro
>  
_______________________________________________
Anthill-pro mailing list
[hidden email]
http://lists.urbancode.com/mailman/listinfo/anthill-pro



_______________________________________________
Anthill-pro mailing list
[hidden email]
http://lists.urbancode.com/mailman/listinfo/anthill-pro