Agent reports "Error retrieving artifacts from Codestation"

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Agent reports "Error retrieving artifacts from Codestation"

Peter Steele

I have a job that I want to run on a particular agent and one of the steps it performs is to retrieve an artifact from a codestation. The agent however reports an error when attempting to retrieve the artifact:

 

2009-10-06 10:14:27,360 ERROR com.urbancode.anthill3.command.codestation2.GetCodestationArtifactsCommand - Error retrieving artifacts from Codestation

java.io.IOException: Operation not supported

        at sun.nio.ch.FileChannelImpl.lock0(Native Method)

        at sun.nio.ch.FileChannelImpl.lock(FileChannelImpl.java:784)

        at com.urbancode.commons.fileutils.sync.SynchronizedDirectory.beginReadAction(SynchronizedDirectory.java:149)

        at com.urbancode.commons.fileutils.sync.DirectoryAccessSynchronizer.beginReadAction(DirectoryAccessSynchronizer.java:78)

        at com.urbancode.codestation2.client.cache.CodestationCache$CachedArtifactSet.<init>(CodestationCache.java:266)

        at com.urbancode.codestation2.client.cache.CodestationCache.openArtifactSetForRead(CodestationCache.java:193)

        at com.urbancode.codestation2.client.CodestationFacade.updateArtifactsCache(CodestationFacade.java:683)

        at com.urbancode.codestation2.client.CodestationFacade.restartableUpdateArtifactsCache(CodestationFacade.java:660)

        at com.urbancode.codestation2.client.CodestationFacade.getArtifactSetFromServer(CodestationFacade.java:614)

        at com.urbancode.codestation2.client.CodestationFacade.retrieveArtifacts(CodestationFacade.java:274)

        at com.urbancode.anthill3.command.codestation2.GetCodestationArtifactsCommand.execute(GetCodestationArtifactsCommand.java:109)

        at com.urbancode.devilfish.services.command.CommandExecutionThread.run(CommandExecutionThread.java:88)

 

I’ve tried different codestations as well as other normal projects and they all give this error. If I run a test job on another agent and try to retrieve the exact same artifact from the same codestation, it works fine. This error only seems to occur on this one system. Everything else runs fine on this agent; it only fails when I use a “Retrieve artifacts from another project” build step. On a few tests instead of throwing an exception, the step hung and I had to kill the job.

 

What would cause this kind of build step to not work on this agent? It’s a FreeBSD agent running 3.5.2.

 

 


_______________________________________________
Anthill-pro mailing list
[hidden email]
http://lists.urbancode.com/mailman/listinfo/anthill-pro